Version Compatibility

Each version of the Camunda Platform is bound to a specific version of the External Task Clients.

Heads Up

Starting with version 7.15.0, Camunda Platform and its compatible Java External Task Client always share the same version.

Camunda Platform version NodeJs Java
7.9.x 1.0.x 1.0.x
7.10.x 1.1.x 1.1.x
7.11.x 1.1.x, 1.2.x 1.2.x
7.12.x 1.3.x 1.3.x
7.13.x 2.0.x 1.3.x
7.14.x 2.0.x 1.4.x
7.15.x 2.0.x 7.15.x

Only these default combinations are recommended (and supported) by Camunda. Nevertheless, each version of the External Task Clients can be combined with newer patch versions of the Camunda Platform Workflow Engine.

On this Page: